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Troubleshoot Session Host Availability


Applies to: Nerdio Manager for MSP (NMM) 

Version : 2.0.0 and greater

Disclaimer : Nerdio Manager for MSP is an automation and management solution. NMM Partners are responsible for understanding, and managing Microsoft Identity Services, M365 and Azure Resources. For Identity and Azure support, please contact your Distributor or Microsoft directly.


Issue:

Session host VM displays the status of "Session Host Unavailable"

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or "AVD Session Host not found"

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Cause:

The status reported here is what NMM receives from Microsoft's AVD Broker/Management Service, which in turn generates the status based on reports from the AVD Agents installed on the session host VMs. 

 

This diagram shows a simplified version of the AVD Agent on a session host sending reports to the AVD "Control Plane" / Management Service

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The statuses are defined as follows:

Available - The AVD Agent is successfully communicating with the AVD Management Service, and is ready to accept User Sessions. 

Unavailable - The AVD Agent has not successfully communicated with the AVD Management Service, or the Agent is unable to update itself to the latest version. This can also will show temporarily while AVD waits for the OS to boot up and the agent to come online. The AVD Agent DID register to the AVD Service.

AVD Session Host not found - NMM has recognized that a VM in Azure was created and linked with NMM, but the corresponding agent was either not installed/registered, or has been removed from AVD's registration list.  The AVD did NOT register to the AVD service.

 

All Session hosts must have the AVD Agent in order to communicate with the AVD Broker service and receive user sessions. The AVD Agent's core components can be found under "Remote Desktop Agent Boot Loader" and "Remote Desktop Services Infrastructure Agent" in Programs and Features.

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Unless the agent is installed, registered to AVD Service, and able to report status, the VM is unable to receive sessions from the AVD management service.

 

Because of this, Nerdio does not allow management of a VM without the AVD Agent installed and registered, since it usually indicates the session host was not successfully created, or there is a significant problem with VM provisioning. Nerdio does this to dissuade using the session host, as an admin should  either perform a "clean up" or "resume" on the session host creation task before continuing with management of the VM.

 

Solution:

The quickest way to resolve this is often to re-image or recreate the session host. This assumes that your Desktop Image is "healthy" and there are no problems with the VM creation task (VM was created successfully without Errors in the task log.)

 

It is also recommended to enable auto-heal under auto-scale settings, which will automatically detect when a session host has problems with availability, and preform reboots and recreation automatically in the event of a failure.

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Optionally, if the session host states "AVD Session host Unavailable", you could attempt to fix the VM Manually, but this is not recommended as it is more labor intensive. Note: This method only works for AVD V2, not AVD V1/"Classic".

To manually fix the issue, you can attempt to uninstall and reinstall the agents on the VM(s) in question. See: https://docs.microsoft.com/en-us/azure/virtual-desktop/create-host-pools-powershell#register-the-virtual-machines-to-the-windows-virtual-desktop-host-pool to download the installer. You will need to retrieve the registration token to use during manual installation:

Go to Azure portal, type in "host pools" 

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Select the hostpool the session host is in, then under overview click "Registration Key" button. Copy the text of the token which is provided, and paste it into the agent installation wizard when prompted.

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