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Transient auto-scale errors


Applies to: Nerdio Manager for MSP (NMM)


Issue:

Errors from the Auto-Scale process are populating the Task log. They look similar to these examples:

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Cause:

The AVD service REST API or Azure Management REST API did not respond to Nerdio Manager successfully. 

Solution:

Typically, this "error" can be safely ignored.

Explanation:
The auto-scale process runs in the background every 5 minutes (by default) for each and every host pool.  That means that if you have 5 host pools with auto-scale enabled, the auto-scale process will run 5x12x24=1440 times per day (5 host pools, 12 times an hour, 24 hours in a day). If you're seeing an occasional error like the ones above, it means that auto-scale couldn't get some information from Azure or AVD (e.g. number of sessions on a host, CPU usage or power state of a particular VM, etc.). 

In our hypothetical example of 5 host pools, if it happens 5 times per day, that's 0.3% of the time. If you're seeing hundreds of these messages then we'd need to investigate.  Otherwise, it has to do with Azure not always responding to API calls absolutely 100% of the time, and this can be safely ignored.

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